Error: Load operation failed for query ‘GetAuthenticationInfo’.

How to solve the error: Load operation failed for query ‘GetAuthenticationInfo’ when deploying a LightSwitch 2012 application to a Windows Server 2008 R2 using IIS.

Scenario: The following error message appears in browser instead of the expected LightSwitch-based web application. The application has been developed using Microsoft LightSwitch in Visual Studio 2012. The application works as expected on the development machine but fails to run in a Microsoft Windows Server 2008 R2 environment even though the LightSwitch server side prerequisites has been installed.

Load operation failed for query ‘GetAuthenticationInfo’. [HttpWebRequest_WebException_RemoteServer]
Arguments: NotFound
Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.30214.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer

Sample Screenshot:

LightSwitch_Error_Screenshot

After some troubleshooting it turns out that it is because the wrong version of WCF Data Services for OData had been installed. The proper version for a Visual Studio 2012 based LightSwitch application is WCF Data Services 5.0 for OData V3 and it is available for download here:
http://www.microsoft.com/en-us/download/details.aspx?id=29306

After installation and a web site restart the application worked as expected.

2 thoughts on “Error: Load operation failed for query ‘GetAuthenticationInfo’.

  1. ken ambrose

    this sucker bit me also and this post helped me a lot. thank you!

    p.s. Now that lightswitch is no longer being enhanced by Microsoft, are you looking for a new app generator? Any suggestions?

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *